Unable to install GhostBSD 4 Beta 1

Questions about the installation of FreeBSD

Moderator: Developer

Unable to install GhostBSD 4 Beta 1

Postby petterk » Tue Jun 03, 2014 3:40 pm


trying to install Ghostbsd 4 Beta 1 on my computer with 2 disks.

Computer: Intel Core2Q6600, Asus P5Q Pro, Adata SSD (disk #1), Seagate Barracuda 500GB (disk #2), Nvidia 8800GTS 640mb.

I have allocated free space on both of them, and none of the disks have more than 1 primary partition on MBR.

First try:

Partitioned manually by selecting the free space on the first disk, and creating new FreeBSD slice, then new partition (UFS-SUJ), mounted to "/".
Did the same on the free space on disk #2, but selected mount-target at "/usr". Also created swap space.

Error came instantly when the install started, telling me "Unknown PTYPE: ada1s3".

Second try: Same as first try, but did not create swap space at all. "Unknown PTYPE: ada1s3" (ada1s3 is the freebsd slice on my second disk)

Third try: Tried selecting the free space on both disks and chose "auto". The partition manager automatically created the slice and the partition on the first disk. Did the same for disk #2, but modifyed the mount point to "/usr" instead of "/". Installation started, but froze after 10minutes, and the installer-window got grey. I could see files being copied and free disk space decrease up until I closed the installer window when the installer had copied 20gb to the disk.
During the first 5 minutes of install, I got several errors about not being able to mount disk. I assume this is caja trying to mount a busy disk.

Fourth try: Tried only using one disk, (disk #1), and partitioned manually. Same error as before: "Unknown Ptype: ada0s3". This is the freebsd slice on my first disk.

Fifth try: Tried using only one disk, and selecting auto. The installer starts, but got error in log saying that gpart could not create partition, because it already existed. Installer exits.

Sixth try: Tried deleting all of the partitions and slices manually before trying the installer. Then same as above. Did not get error, but midway through the installer-window closed itself. I could still see disk being used and I manually rebooted the computer when the installer had copied 30gigs of material from USB-installer. I went into the directory ".gbi" and opened up the "tmp" file. I could see infinately entries of the same files being copied, like this:

/mnt/cdinstall-mnt (or something similar)/some-directory/some-files

You see? The same files just copied one directory deeper. Im guessing this is why the installer filled up my disks with 30gigs. The same files were being used multiple times just a directory deeper.

Hope this helps.
Posts: 6
Joined: Thu Dec 05, 2013 4:42 pm

Unable to install GhostBSD 4 Beta 1

Re: Unable to install GhostBSD 4 Beta 1

Postby ericbsd » Tue Jun 03, 2014 11:21 pm


This is shame on me I had forgot to prevent the install Back end to copy /mnt, /media contain. I had fix that last weekend, right now I am doing some improvement on the front end user interface of the installer and some tweaking on the partition interaction.

Oh and thanks to reporting that problem.
Posts: 730
Joined: Mon Nov 19, 2012 11:54 pm

Re: Unable to install GhostBSD 4 Beta 1

Postby petterk » Wed Jun 04, 2014 1:50 pm

No problem, hope you get it up and running for your next beta or release candidate. :)
Posts: 6
Joined: Thu Dec 05, 2013 4:42 pm

Return to Installing GhostBSD

Who is online

Users browsing this forum: No registered users and 1 guest