Problem installing and configuring Broadcom BCM4312 LP-PHY

Help with setting up network cards, including WiFi cards.

Problem installing and configuring Broadcom BCM4312 LP-PHY

Postby aigon89 » Sun Mar 09, 2014 12:00 pm

Hi everyone,

It's my first time here so please be gentle.

I'm coming from Linux world and it's also my first time in BSD world.

I've used Lubuntu previously on this PC and managed to get the Wireless adapter working but I've found that here on BSD it's quite more difficult.

I've managed to install bwm module following every step on FreeBSD docs and the system recognizes the Wireless adapter and shows it as bwn0:

Code: Select all
bwn0: flags=8803<UP,BROADCAST,SIMPLEX,MULTICAST> metric 0 mtu 2290
   ether 00:24:2c:0e:c5:8a
   nd6 options=29<PERFORMNUD,IFDISABLED,AUTO_LINKLOCAL>
   media: IEEE 802.11 Wireless Ethernet autoselect mode 11b
   status: associated


Then, the FreeBSD guide doc asks to run:
Code: Select all
sudo ifconfig wlan0 create wlandev bwn0

Which works too, creating a new interface called wlan0 as expected. Then, I want to list the networks around here running:
Code: Select all
sudo ifconfig wlan0 up

At this point, the Wireless LED light doesn't turn on, but overlooking at this, I run:
Code: Select all
sudo ifconfig wlan0 list scan

But nothing happens.
Here are the contents of /etc/rc.conf and /boot/loader.conf:
/boot/loader.conf
Code: Select all
                           
if_bwn_load="YES"
bwn_v4_lp_ucode="YES"
wlan_wep_load="YES"
wlan_ccmp_load="YES"
wlan_tkip_load="YES"
wlan_scan_ap_load="YES"
wlan_scan_sta_load="YES"

/etc/rc.conf
Code: Select all
# Network interface.
ifconfig_ale0="DHCP"
# Power saver.
powerd_enable="YES"
powerd_flags="-a adp -b adp"

# DEVFS rules
devfs_system_ruleset="system"

# All Gnome need.
cupsd_enable="YES"
gdm_enable="YES"
hald_enable="YES"
dbus_enable="YES"
linux_enable="YES"

gdm_lang="es_ES.UTF-8"
keymap="spanish.iso"
hostname="netbook"


Thanks and best regards to everyone!
aigon89
 
Posts: 2
Joined: Sun Mar 09, 2014 11:42 am

Problem installing and configuring Broadcom BCM4312 LP-PHY

 

Re: Problem installing and configuring Broadcom BCM4312 LP-P

Postby ericbsd » Sun Mar 09, 2014 4:36 pm

in /etc/rc.conf add
Code: Select all
 # Network interface.
ifconfig_ale0="DHCP"
# Your wifi configuration
wlans_bwn0="wlan0"
ifconfig_wlan0="WPA DHCP"
# Power saver.
powerd_enable="YES"
powerd_flags="-a adp -b adp"

# DEVFS rules
devfs_system_ruleset="system"

# All Gnome need.
cupsd_enable="YES"
gdm_enable="YES"
hald_enable="YES"
dbus_enable="YES"
linux_enable="YES"

gdm_lang="es_ES.UTF-8"
keymap="spanish.iso"
hostname="netbook"
ericbsd
Site Admin
 
Posts: 379
Joined: Mon Nov 19, 2012 11:54 pm

Re: Problem installing and configuring Broadcom BCM4312 LP-P

Postby aigon89 » Sun Mar 09, 2014 6:04 pm

Added, but the result is the same.

I'll keep investigating.

Thanks!
aigon89
 
Posts: 2
Joined: Sun Mar 09, 2014 11:42 am

Re: Problem installing and configuring Broadcom BCM4312 LP-P

Postby ericbsd » Sun Mar 09, 2014 6:08 pm

Broadcom on FreeBSD are not well supported.
ericbsd
Site Admin
 
Posts: 379
Joined: Mon Nov 19, 2012 11:54 pm


Return to Networking

Who is online

Users browsing this forum: No registered users and 1 guest

cron