Page 1 of 1

Package Manager

PostPosted: Wed Mar 20, 2013 10:56 am
by Aquila
Hi, I tried to install GhostBSD 3 but package manager does not work or is not installed. Update Package do when she says "Your system 9.1-RELEASE is unknown! Try updating bxpkg or supply with a repository URL - repo-site option '.

Re: Package Manager

PostPosted: Thu Mar 21, 2013 6:23 pm
by ericbsd
Did you read the newsletter on the ghostbsd.org?
Please note that precompiled third-party packages are not available for 9.1-RELEASE at the time of release. The Package Manager and pkg_add will not function to install application. To install app you need to build it from FreeBSD Ports See Using the Ports Collection for Help.

Re: Package Manager

PostPosted: Fri Mar 22, 2013 12:09 pm
by Aquila
Hi, So I have to use to install software on FreeBSD as the ports, but the release 3.0 is not stable yet?

Re: Package Manager

PostPosted: Fri Mar 22, 2013 4:47 pm
by ericbsd
3.0 is the stable version and it is base on FreeBSD 9.1 which the package is not out yet. GhostBSD don't distribute is own pkg.

Re: Package Manager

PostPosted: Sun Mar 24, 2013 5:46 am
by Aquila
But if I install programs via the FreeBSD ports that would be friendly distro?
It takes my entire installation of Free but then what??
I had already tried Ghost time ago but found it yet mature, now, I was hoping you so much to replace Linux.
And I'm not just a newbe, since I installed NetBSD but due to lack of programs that serve me I took it off.
Hello.

Re: Package Manager

PostPosted: Sun Mar 24, 2013 6:42 am
by ericbsd
Aquila wrote:But if I install programs via the FreeBSD ports that would be friendly distro?
It takes my entire installation of Free but then what??


For the first time GhostBSD have no pkg to offer because of FreeBSD problem.

Port are friendly if you know how to use it. Its way better then pkg_add -r or apt-get install. since you compile every software you can chose option then precompile package cant offer.
But it take more time to install.

GhostBSD was made to make a bridge between FreeBSD default system and normal desktop user. GhostBSD depend totally on FreeBSD and is 100% FreeBSD.

I plan to get my own pkg repository but for the moment is not possible. It will cost my to much money and to get that up.

Not enough people are interesting to help the project strive. that is what make this project like you see it today.

Re: Package Manager

PostPosted: Tue Mar 26, 2013 11:41 am
by Aquila
Hello,
I installed the program via ports, but I can not install Gimp 2.8.4.
I also have problems with server, and Internet Mail.
I like to tinker, but I'm asking if I do not the computer!

Re: Package Manager

PostPosted: Tue Mar 26, 2013 3:28 pm
by ericbsd
To install gimp you will need to update to all the package in your system which take a lot of time.