Critical problem after pkg upgrade  [SOLVED]

Need support for GhostBSD. Ask here if your question does not fit elsewhere.

Critical problem after pkg upgrade

Postby Jes » Tue Apr 04, 2017 4:00 pm

My computer is in 10.3. After a 'pkg upgrade' today with about 900 packages to be upgraded the system is unable to start fine any desktop. I've tried mate, xfce4 and kde4. My login manager is kdm4. kdm4 starts fine, but after login xfce4 seems to be frozen, with black screen except mouse, mouse is visible and working.

If I start graphical wm from console with "startx" and "exec mate-session" in .xinitrc the behaviour is more or less the same. Mate try to start, showing the battery icon in the top, and the workspace pager in the botton, and the mouse, but the rest remains black.

Before "pkg upgrade" I was able to initiate kde4, mate, xfce4, enlightenment, etc. No modifications in any system file (xorg.conf or so) was done.

My computer is a thinkpad T420s with intel driver in xorg.conf.

Any idea?


Thanks
Jes
 
Posts: 31
Joined: Sun Dec 25, 2016 2:43 pm
Location: Spain
Has thanked: 13 times
Been thanked: 10 times

Critical problem after pkg upgrade


Re: Critical problem after pkg upgrade

Postby Jes » Tue Apr 04, 2017 4:22 pm

Solved but....

My xorg.conf had:

Driver "intel"
Option "AccelMethod" "sna"


Changing the accelmethod to:

Option "AccelMethod" "uxa"

fix the problem. But this didn't happen just yesterday, for example, before upgrade.

It's supposed "sna" is better for Sandbridge and Ivybridge gpus.

Anyone with the same issue?

Thanks
Jes
 
Posts: 31
Joined: Sun Dec 25, 2016 2:43 pm
Location: Spain
Has thanked: 13 times
Been thanked: 10 times

Re: Critical problem after pkg upgrade

Postby ASX » Tue Apr 04, 2017 5:24 pm

what you are experiencing is related to today 'quarterly' branch switch (from 2017Q1 to 2017Q2); lately a series of updates related to mesa, xorg, and other graphics related stuffs reached the "quarterly" repository.

Similar issues has been reported on freebsd forum in the past weeks (from those using the "latest" repository), often solutions and workaround appeared out days later, but not always.

I would say the situation is still a but unstable in that respect, not much we can do about until we complete our own repository setup (yeah, we are working on that).
ASX
Developer
 
Posts: 901
Joined: Wed May 06, 2015 11:46 am
Has thanked: 50 times
Been thanked: 112 times

Re: Critical problem after pkg upgrade  [SOLVED]

Postby Jes » Wed Apr 05, 2017 5:27 am

That's what I supposed, but I didn't find any page or post. Thank you very much ASX.

BR

Jes
Jes
 
Posts: 31
Joined: Sun Dec 25, 2016 2:43 pm
Location: Spain
Has thanked: 13 times
Been thanked: 10 times


Return to General support

Who is online

Users browsing this forum: No registered users and 1 guest

cron