GhostBSD 4.0 BETA1

Share your ideas, questions or suggestions with us here.

GhostBSD 4.0 BETA1

Postby bsdkeith » Thu Jun 05, 2014 5:43 pm

Using i386.img dd'ed to pendrive.

Running live :-
Wrong keyboard & no wifi, wifi manager said none found.
Used setxkbmap gb to sort out the keyboard mapping.
Configured wifi with settings written down from a 3.1 install, /etc/rc.conf & /etc/wpa_supplicant.conf, & ran service netif start. Still no wifi connection.
Tryed logging out & back in, restarting netif, stopping & starting netif, to no avail.

Tried to install :-
Using whole disk & boot loader,
Strapline reads 'Welcome to GhostBSD 3.5' - will need changing.

First attempt starting from desktop icon, somewhere after a while the installer just disappeared from the screen, so, I thought maybe it finished but didn't tell me.
So rebooted from hard drive (installation), which brought me to a 'mountroot>' prompt, stating error 19. (That install I left 'fish' as the shell.)

Second attempt, running gbi from the commandline, I noticed that there were an awful lot of /mnt/mnt/mnt before the filename being installed, I managed to count 32 /mnt before the filename at one stage!
The installer seemed to be adding an extra /mnt with each file being installed. Anyway, the installer crashed whilst adding /compat/linux/sbin/mkfs.ext4dev.
I also took note that /dev/ada0p2 was mounted on /mnt. On trying to boot from hard drive this time, came to the same 'mountroot>' prompt, I tried entering ufs:/dev/ada0p2 & various other permutations that I could think of, but kept getting 'error 19'.

So there seems to me to be a problem with the installer script & maybe wifi configuration with the wifi manager.
(Didn't think it worth going any further with testing at this time/stage.)

All the best,
Keith.
Linux user between 1999 - 2014; now a BSD user.
User avatar
bsdkeith
 
Posts: 94
Joined: Wed Jun 12, 2013 6:36 pm
Location: Surrey/Hants Border, England

GhostBSD 4.0 BETA1

 

Re: GhostBSD 4.0 BETA1

Postby ericbsd » Sat Jun 14, 2014 2:00 pm

Can you give me the full outpout of:
Code: Select all
ifconfig
ericbsd
Site Admin
 
Posts: 338
Joined: Mon Nov 19, 2012 11:54 pm

Re: GhostBSD 4.0 BETA1

Postby bsdkeith » Sat Jun 14, 2014 2:21 pm

Will have to get back to you on that one. The laptop that I was using has now got FreeBSD 10.0 (with Fluxbox) on it. :)
I shall dd 4.0BETA1 to pendrive again & try running it live on there to get the results from ifconfig.
I'm afraid this machine I'm on at the moment is running one of the competition. :lol: (PC-BSD10 'straight out of the box')
It looks like I will be using BSD more in the future - they say a change is as good as a rest. :geek:
Linux user between 1999 - 2014; now a BSD user.
User avatar
bsdkeith
 
Posts: 94
Joined: Wed Jun 12, 2013 6:36 pm
Location: Surrey/Hants Border, England

Re: GhostBSD 4.0 BETA1

Postby bsdkeith » Sat Jun 14, 2014 4:20 pm

I can't attach files; 'the extension isn't allowed' (!?)
So....
Here is the 'ifconfig' from that laptop running the i386.img live.

Code: Select all
re0: flags=8802<BROADCAST,SIMPLEX,MULTICAST> metric 0 mtu 1500
   options=8209b<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,VLAN_HWCSUM,WOL_MAGIC,LINKSTATE>
   ether 00:03:0d:7b:79:ba
   nd6 options=29<PERFORMNUD,IFDISABLED,AUTO_LINKLOCAL>
   media: Ethernet autoselect (none)
   status: no carrier
lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> metric 0 mtu 16384
   options=600003<RXCSUM,TXCSUM,RXCSUM_IPV6,TXCSUM_IPV6>
   inet6 ::1 prefixlen 128
   inet6 fe80::1%lo0 prefixlen 64 scopeid 0x2
   inet 127.0.0.1 netmask 0xff000000
   nd6 options=21<PERFORMNUD,AUTO_LINKLOCAL>
rum0: flags=8802<BROADCAST,SIMPLEX,MULTICAST> metric 0 mtu 2290
   ether 00:1d:92:12:51:08
   nd6 options=29<PERFORMNUD,IFDISABLED,AUTO_LINKLOCAL>
   media: IEEE 802.11 Wireless Ethernet autoselect <adhoc> (autoselect <adhoc>)
   status: no carrier


Here is what it is in the underlying FreeBSD10.0 system.

Code: Select all
re0: flags=8802<BROADCAST,SIMPLEX,MULTICAST> metric 0 mtu 1500
   options=8209b<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,VLAN_HWCSUM,WOL_MAGIC,LINKSTATE>
   ether 00:03:0d:7b:79:ba
   nd6 options=29<PERFORMNUD,IFDISABLED,AUTO_LINKLOCAL>
   media: Ethernet autoselect (none)
   status: no carrier
lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> metric 0 mtu 16384
   options=600003<RXCSUM,TXCSUM,RXCSUM_IPV6,TXCSUM_IPV6>
   inet6 ::1 prefixlen 128
   inet6 fe80::1%lo0 prefixlen 64 scopeid 0x2
   inet 127.0.0.1 netmask 0xff000000
   nd6 options=21<PERFORMNUD,AUTO_LINKLOCAL>
rum0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 2290
   ether 00:1d:92:12:51:08
   nd6 options=29<PERFORMNUD,IFDISABLED,AUTO_LINKLOCAL>
   media: IEEE 802.11 Wireless Ethernet autoselect mode 11g
   status: associated
wlan0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
   ether 00:1d:92:12:51:08
   inet 192.168.1.83 netmask 0xffffff00 broadcast 192.168.1.255
   nd6 options=29<PERFORMNUD,IFDISABLED,AUTO_LINKLOCAL>
   media: IEEE 802.11 Wireless Ethernet OFDM/48Mbps mode 11g
   status: associated
   ssid BTHub3-NM6S channel 6 (2437 MHz 11g) bssid 00:fe:f4:70:12:98
   country US authmode WPA2/802.11i privacy ON deftxkey UNDEF
   TKIP 2:128-bit txpower 0 bmiss 7 scanvalid 60 bgscan bgscanintvl 300
   bgscanidle 250 roam:rssi 7 roam:rate 5 protmode CTS roaming MANUAL


The live rc.conf.

Code: Select all
#
# See /etc/defaults/rc.conf to add more option.
# Do not configure /etc/defaults/rc.conf.
# Configure only this file.
#

# Network interface.
hostname="livecd"

# Power saver.
powerd_enable="YES"
powerd_flags="-a adp -b adp"

# DEVFS rules
devfs_system_ruleset="system"

# All Gnome need.
cupsd_enable="YES"
gdm_enable="YES"
hald_enable="YES"
dbus_enable="YES"
linux_enable="YES"

vboxguest_enable="YES"
vboxservice_enable="YES"


The FreeBSD10.0 rc.conf.

Code: Select all
hostname="advent"
keymap="uk.iso.kbd"
wlans_rum0="wlan0"
ifconfig_wlan0="WPA DHCP"
sshd_enable="YES"
dumpdev="NO"
hald_enable="YES"
dbus_enable="YES"


There was no live wpa_supplicant. (Seems like this may be part of the problem.)

The FreeBSD10.0 wpa_supplicant.

Code: Select all
ctrl_interface=/var/run/wpa_supplicant
eapol_version=2
ap_scan=1
fast_reauth=1

network={
   ssid="my-hub"
   psk="my-key"
   priority=5
}
network={
   priority=5
   key_mgmt=NONE
}
Linux user between 1999 - 2014; now a BSD user.
User avatar
bsdkeith
 
Posts: 94
Joined: Wed Jun 12, 2013 6:36 pm
Location: Surrey/Hants Border, England

Re: GhostBSD 4.0 BETA1

Postby ericbsd » Sat Jun 14, 2014 5:40 pm

I have try GhostBSD 4.0 i386.img on my new laptop I had notice that the network manager is present on i386.
ericbsd
Site Admin
 
Posts: 338
Joined: Mon Nov 19, 2012 11:54 pm

Re: GhostBSD 4.0 BETA1

Postby bsdkeith » Sat Jun 14, 2014 7:26 pm

Network Manager comes up, but says there are no networks found.
Not sure if my wifi card driver is in the GhostBSD kernel. It works OK with my FreeBSD install, it was configured as part of the installation.
Linux user between 1999 - 2014; now a BSD user.
User avatar
bsdkeith
 
Posts: 94
Joined: Wed Jun 12, 2013 6:36 pm
Location: Surrey/Hants Border, England

Re: GhostBSD 4.0 BETA1

Postby ericbsd » Sat Jun 14, 2014 11:25 pm

I have find all problem I had my self right now. I will since My new laptop Lenevo ThinkPad T530 use iwn I have found fix for all iwn card supported by FreeBSD kernel.

I also see that that your card has not been configured by Networkmrg from the log you gave me and that is also why wpa_supplicant.conf is not present.
I said,
I have try GhostBSD 4.0 i386.img on my new laptop I had notice that the network manager is present on i386.


But I have omitted a word - I have try GhostBSD 4.0 i386.img on my new laptop I had notice that the network manager is "not" present on i386.

When refer to the network manager I refer to the one we are making not the FreeBSD Wifi Network Manager.
ericbsd
Site Admin
 
Posts: 338
Joined: Mon Nov 19, 2012 11:54 pm

Re: GhostBSD 4.0 BETA1

Postby bsdkeith » Sun Jun 15, 2014 9:35 am

Will you be releasing another version of BETA1 or shall I wait for BETA2?
Linux user between 1999 - 2014; now a BSD user.
User avatar
bsdkeith
 
Posts: 94
Joined: Wed Jun 12, 2013 6:36 pm
Location: Surrey/Hants Border, England

Re: GhostBSD 4.0 BETA1

Postby ericbsd » Sun Jun 15, 2014 10:43 am

I will release a BETA2 soon. I am experiencing some problem.
ericbsd
Site Admin
 
Posts: 338
Joined: Mon Nov 19, 2012 11:54 pm


Return to Feedback

Who is online

Users browsing this forum: No registered users and 2 guests