ditched wireless, went wired and still no internet

Help with setting up network cards, including WiFi cards.

ditched wireless, went wired and still no internet

Postby lizbeth » Wed Sep 17, 2014 7:29 am

I just tried to use gbsd 4.0 rc2 from usb with a new copy. It booted once into the livecd mode i had a wired connection active but couldnt surf the internet. checked for proxies and permissions issues with the livecd but that didnt avail anything. im makeing a fresh usb with 3.5. is it a livecd also?

I saw in another post you asked for ifconfigt and cat/etc/rc.conf output. im wired from the router so it should work yes?

Anyway, give me a litle aide here please. thanks.
lizbeth
 
Posts: 20
Joined: Sun Sep 07, 2014 11:04 pm

ditched wireless, went wired and still no internet

 

Re: ditched wireless, went wired and still no internet

Postby bsdkeith » Wed Sep 17, 2014 8:04 am

All GhostBSD CD/DVD's are live installable, (as are the 'image' files).
There has been some problems with missing software on some 4.0RC releases, mainly 32bit.
Many people say they had 3.5 up and running, so no harm in trying it.
Linux user between 1999 - 2014; now a BSD user.
User avatar
bsdkeith
 
Posts: 102
Joined: Wed Jun 12, 2013 6:36 pm
Location: Surrey/Hants Border, England

Re: ditched wireless, went wired and still no internet

Postby lizbeth » Wed Sep 17, 2014 4:38 pm

Levi didnt like my monitor something...xinit unable to connect to server connection refused bad display name livecd:0 in remove command.

tried 4.0 again. booted into livecd mode, again no internet despite ghost showing a wired internet connection (the one im now using from a solydxk livecd mode)

ifconfig from gbsd 4.0 says:


[lizzi@ghost-bsd ~]$ ifconfig
alc0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
options=c3198<VLAN_MTU,VLAN_HWTAGGING,VLAN_HWCSUM,TSO4,WOL_MCAST,WOL_MAGIC,VLAN_HWTSO,LINKSTATE>
ether 00:00:00:00:00:00
inet 0.0.0.0 netmask 0xff000000 broadcast 255.255.255.255
nd6 options=29<PERFORMNUD,IFDISABLED,AUTO_LINKLOCAL>
media: Ethernet autoselect (100baseTX <full-duplex>)
status: active
lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> metric 0 mtu 16384
options=600003<RXCSUM,TXCSUM,RXCSUM_IPV6,TXCSUM_IPV6>
inet6 ::1 prefixlen 128
inet6 fe80::1%lo0 prefixlen 64 scopeid 0x2
inet 127.0.0.1 netmask 0xff000000
nd6 options=21<PERFORMNUD,AUTO_LINKLOCAL>
[lizzi@ghost-bsd ~]$




rc.conf from gbsd 4.0 says:


[lizzi@ghost-bsd ~]$ cat /etc/rc.conf
#
# See /etc/defaults/rc.conf to add more option.
# Do not configure /etc/defaults/rc.conf.
# Configure only this file.
#
# Power saver.
powerd_enable="YES"
powerd_flags="-a adp -b adp"
# DEVFS rules
devfs_system_ruleset="system"
# All Gnome need.
cupsd_enable="YES"
gdm_enable="YES"
hald_enable="YES"
dbus_enable="YES"
linux_enable="YES"
# Virtual Box adition configuration
vboxguest_enable="YES"
vboxservice_enable="YES"

#Netork card configuration by Networkmgr
ifconfig_alc0="DHCP"
gdm_lang="en_US.UTF-8"
keymap="us.iso"
hostname="ghost-bsd"
[lizzi@ghost-bsd ~]$






May I please have some assistance getting ghost 4.0 to connect to the internet?
lizbeth
 
Posts: 20
Joined: Sun Sep 07, 2014 11:04 pm

Re: ditched wireless, went wired and still no internet

Postby ericbsd » Sat Sep 20, 2014 9:44 pm

I am sorry that I have not reply sooner.

Can you give me the terminal output of
Code: Select all
ifconfig
ericbsd
Site Admin
 
Posts: 404
Joined: Mon Nov 19, 2012 11:54 pm

Re: ditched wireless, went wired and still no internet

Postby lizbeth » Sun Sep 21, 2014 5:17 am

It is posted in the post above yours
lizbeth
 
Posts: 20
Joined: Sun Sep 07, 2014 11:04 pm

Re: ditched wireless, went wired and still no internet

Postby lizbeth » Sun Sep 21, 2014 5:18 am


Re: ditched wireless, went wired and still no internet

Postby lizbeth » Wed Sep 17, 2014 11:38 am
Levi didnt like my monitor something...xinit unable to connect to server connection refused bad display name livecd:0 in remove command.

tried 4.0 again. booted into livecd mode, again no internet despite ghost showing a wired internet connection (the one im now using from a solydxk livecd mode)

ifconfig from gbsd 4.0 says:


[lizzi@ghost-bsd ~]$ ifconfig
alc0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
options=c3198<VLAN_MTU,VLAN_HWTAGGING,VLAN_HWCSUM,TSO4,WOL_MCAST,WOL_MAGIC,VLAN_HWTSO,LINKSTATE>
ether 00:00:00:00:00:00
inet 0.0.0.0 netmask 0xff000000 broadcast 255.255.255.255
nd6 options=29<PERFORMNUD,IFDISABLED,AUTO_LINKLOCAL>
media: Ethernet autoselect (100baseTX <full-duplex>)
status: active
lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> metric 0 mtu 16384
options=600003<RXCSUM,TXCSUM,RXCSUM_IPV6,TXCSUM_IPV6>
inet6 ::1 prefixlen 128
inet6 fe80::1%lo0 prefixlen 64 scopeid 0x2
inet 127.0.0.1 netmask 0xff000000
nd6 options=21<PERFORMNUD,AUTO_LINKLOCAL>
[lizzi@ghost-bsd ~]$
lizbeth
 
Posts: 20
Joined: Sun Sep 07, 2014 11:04 pm

Re: ditched wireless, went wired and still no internet

Postby ericbsd » Sun Sep 21, 2014 11:17 am

My bad, sorry again. I see your inet is not assign to a IP.

If you now your router network IP it replace mine by yours.

My internal network IP is 192.268.0.1 which is most likely the default IP of most router.
The IP I will assign is 192.268.0.14.

Code: Select all
ifconfig alc0 inet 192.168.0.14/24


you might need to replace
Code: Select all
ifconfig_alc0="DHCP"

by
Code: Select all
ifconfig_fxp0="inet 192.168.0.14  netmask 255.255.255.0"


Let me know if it work.
ericbsd
Site Admin
 
Posts: 404
Joined: Mon Nov 19, 2012 11:54 pm

Re: ditched wireless, went wired and still no internet

Postby lizbeth » Sun Sep 21, 2014 11:45 pm

The first command gets me as far as my router admin page but not to the Internet. The second command gets me no further. It says did you mean set ifconfig_fxp0 inet 192.168.1.14 net ask 255.255.255.0. ? Without the quotes and the equals sign
lizbeth
 
Posts: 20
Joined: Sun Sep 07, 2014 11:04 pm

Re: ditched wireless, went wired and still no internet

Postby lizbeth » Sun Sep 21, 2014 11:46 pm

Re entered without the quotes and equals sign and still no internet. Cable modem admin page. The cable modem says I am connected to the Internet by the way,
lizbeth
 
Posts: 20
Joined: Sun Sep 07, 2014 11:04 pm

Re: ditched wireless, went wired and still no internet

Postby lizbeth » Mon Sep 22, 2014 12:03 am

Oh ok I'm slow, you mean swap those lines in re.conf?
lizbeth
 
Posts: 20
Joined: Sun Sep 07, 2014 11:04 pm

Next

Return to Networking

Who is online

Users browsing this forum: No registered users and 1 guest