gBSD 4.0 fails to load on Intel onboard Ivy bridge graphics.

Questions about the installation of FreeBSD

gBSD 4.0 fails to load on Intel onboard Ivy bridge graphics.

Postby mzs_47 » Sun Oct 05, 2014 4:25 am

Hello,
I downloaded the 64bit .img release file of gBSD.
The system boots up fine till the GUI, I can see the mouse pointer on console(CLI). After which the screen goes blank and my monitor shows "no signal" message.
I can see the num lock on and I cannot toggle it nor can I see the USB lighting up after this, so that means the system froze.

I followed the first steps described on gBSD wiki and changed the IGP settings from auto to enabled and changed the shared memory to max.
http://wiki.ghostbsd.org/index.php?title=Installation_Troubleshooting

I then tried dropping to the boot loader prompt to execute following->

Code: Select all
     unload
    disable-module vesa
    set module_path=/boot/kernel;/boot/modules;CONSOLE
    boot


However it fails at
Code: Select all
disable-module vesa
saying command not found.

My Hardware-
Intel Pentium G2030
Motherboard- Gagiabyte GA-B75-D3H

On Linux mint 17 64bit with xfce ->

Code: Select all
$ lspci -vnn|grep VGA -A 12
00:02.0 VGA compatible controller [0300]: Intel Corporation Xeon E3-1200 v2/3rd Gen Core processor Graphics Controller [8086:0152] (rev 09) (prog-if 00 [VGA controller])
   Subsystem: Gigabyte Technology Co., Ltd Device [1458:d000]
   Flags: bus master, fast devsel, latency 0, IRQ 43
   Memory at f7800000 (64-bit, non-prefetchable) [size=4M]
   Memory at e0000000 (64-bit, prefetchable) [size=256M]
   I/O ports at f000 [size=64]
   Expansion ROM at <unassigned> [disabled]
   Capabilities: <access denied>
   Kernel driver in use: i915



I tried using this live USB on my brother's PC with Nvidia, and It works. I went intel just because of FreeBSD and Linux support. But looks like Nvidia is better supported :o
I don't know what else can I try.
mzs_47
 
Posts: 7
Joined: Sun Feb 16, 2014 10:07 am

gBSD 4.0 fails to load on Intel onboard Ivy bridge graphics.

 

Re: gBSD 4.0 fails to load on Intel onboard Ivy bridge graph

Postby ericbsd » Mon Oct 06, 2014 9:42 pm

Its something that I don't get about Intel I have Lenovo T530 with and 4000M Intel graphic card witch work fine. I now that some people who have tried PC-BSD They have no problem I just don't know what I do wrong. I need people that can make work that hardware on FreeBSD for this project, but for the moment no body look to be interested to do that. If I compile X without hald that will fix the problem.
ericbsd
Site Admin
 
Posts: 427
Joined: Mon Nov 19, 2012 11:54 pm

Re: gBSD 4.0 fails to load on Intel onboard Ivy bridge graph

Postby mzs_47 » Tue Oct 07, 2014 1:53 am

ericbsd wrote:Its something that I don't get about Intel I have Lenovo T530 with and 4000M Intel graphic card witch work fine. I now that some people who have tried PC-BSD They have no problem I just don't know what I do wrong. I need people that can make work that hardware on FreeBSD for this project, but for the moment no body look to be interested to do that. If I compile X without hald that will fix the problem.


Thanks Eric.

Yes I tried PC-BSD 10.0.3(latest stable) and it boots up fine with proper resolution.
I can help you with this hardware, but just after this week(after 11 October) I am moving to a new place where I won't be taking this machine.

So I am not sure how much of help that could be to you.
Right now I am running Mint 17 64bit XFCE. I have kept a partion just for gBSD.

Let me know what else can I try. I will send back the results to you.
mzs_47
 
Posts: 7
Joined: Sun Feb 16, 2014 10:07 am

Re: gBSD 4.0 fails to load on Intel onboard Ivy bridge graph

Postby ericbsd » Tue Oct 07, 2014 4:54 pm

I have contact Kris and I think I found what I did wrong. I will release beta 4.1 with change some change to see what if it get better.
ericbsd
Site Admin
 
Posts: 427
Joined: Mon Nov 19, 2012 11:54 pm

Re: gBSD 4.0 fails to load on Intel onboard Ivy bridge graph

Postby ericbsd » Tue Oct 07, 2014 5:05 pm

Eh Can you give my your /etc/X11/xorg.conf in PCBSD?
ericbsd
Site Admin
 
Posts: 427
Joined: Mon Nov 19, 2012 11:54 pm

Re: gBSD 4.0 fails to load on Intel onboard Ivy bridge graph

Postby mzs_47 » Wed Oct 08, 2014 1:43 am

ericbsd wrote:Eh Can you give my your /etc/X11/xorg.conf in PCBSD?


Sorry, I could not install it.
Installation fails at initial step which shows "stamping /dev/adapx for booting" or smothing like that and my bios_grub partion gets corrupted, which in turn is affecting Linux Mint boot.
I tried various combiantions of bootloader options- GRUB-SLICE, NONE, and GRUB. None of them worked.

I recovered the grub using boot repair utility -> https://help.ubuntu.com/community/Boot-Repair

As I am installing on SSD I made swap size equal to zero. PC-BSD installer defaults it at 2000MB. I should try setting the swap to some non-zero value.
mzs_47
 
Posts: 7
Joined: Sun Feb 16, 2014 10:07 am


Return to Installing GhostBSD

Who is online

Users browsing this forum: No registered users and 0 guests

cron