nspluginwrapper

Installing and maintaining software with the FreeBSD Ports Collection.

Moderator: Developer

nspluginwrapper

Postby galasrinnion » Tue Oct 28, 2014 10:19 pm

Trying to install nspluginwrapper.
Got this at the end of the attempted install.
===> linux-f10-png-1.2.37_2 has known vulnerabilities:
linux-f10-png-1.2.37_2 is vulnerable:
png -- memory corruption/possible remote code execution
CVE: CVE-2011-3048
WWW: http://portaudit.FreeBSD.org/262b92fe-8 ... 78670.html

1 problem(s) in the installed packages found.
=> Please update your ports tree and try again.
=> Note: Vulnerable ports are marked as such even if there is no update available.
=> If you wish to ignore this vulnerability rebuild with 'make DISABLE_VULNERABILITIES=yes'
*** Error code 1

Stop.
make[2]: stopped in /usr/ports/graphics/linux-f10-png
*** Error code 1

Stop.
make[1]: stopped in /usr/ports/graphics/linux-f10-cairo
*** Error code 1

Stop.
make: stopped in /usr/ports/www/nspluginwrapper


What needs to be done from this point ?
User avatar
galasrinnion
 
Posts: 39
Joined: Tue Oct 28, 2014 3:45 pm

nspluginwrapper

 

Re: nspluginwrapper

Postby galasrinnion » Fri Oct 31, 2014 3:16 pm

Here's the output of a second attempt to install nspluginwrapper, from the end of the output :

===> Verifying install for /compat/linux/usr/lib/libcairo.so.2.10800.0 in /usr/ports/graphics/linux-f10-cairo
touch: /usr/ports/graphics/linux-f10-cairo/work/.build_done.cairo._compat_linux: Permission denied
*** Error code 1

Stop.
make[1]: stopped in /usr/ports/graphics/linux-f10-cairo
*** Error code 1

Stop.
User avatar
galasrinnion
 
Posts: 39
Joined: Tue Oct 28, 2014 3:45 pm

Re: nspluginwrapper

Postby ericbsd » Sun Nov 02, 2014 12:32 pm

I did have the same problem something was not compiling, but if you update your ports tree you should be able to have it work.
ericbsd
Developer
 
Posts: 700
Joined: Mon Nov 19, 2012 11:54 pm

Re: nspluginwrapper

Postby Grenouille » Fri Nov 13, 2015 1:55 pm

I attempted to install flash using the method suggested here : http://wiki.ghostbsd.org/index.php?title=Installing_Adobe_Flash_Plugin

Installing nspluginwrapper works properly, but then attempting to install linux-f10-flashplugin11 gives me the following error :

Code: Select all
pkg-static: linux-f10-atk-1.24.0_1 conflicts with linux-c6-atk-1.30.0 (installs files into the same place).  Problematic file: /compat/linux/usr/lib/libatk-1.0.so.0
*** Error code 70


EDIT : I was fine installing linux-c6-flashplugin11 instead of linux-f10-flashplugin11, so the Flash player is installed. The problem is now : the sound doesn't work (tried on deezer.com) During installation it was written that ALSA audio was broken and needed "lemul". I don't know what I have to do now ?
Grenouille
 
Posts: 10
Joined: Fri Nov 13, 2015 10:44 am
Location: Europe


Return to Installation and Maintenance of software with Ports

Who is online

Users browsing this forum: No registered users and 0 guests

cron