Anybody else having issues with Ports

Installing and maintaining software with the FreeBSD Ports Collection.

Re: Anybody else having issues with Ports

Postby fmh » Sun Jan 04, 2015 2:23 pm

Since I can't boot the VM how would I install Mate? Boot into the Command Line in Single User Mode?
fmh
 
Posts: 64
Joined: Wed Jul 23, 2014 5:07 pm

Re: Anybody else having issues with Ports

 

Re: Anybody else having issues with Ports

Postby ericbsd » Sun Jan 04, 2015 6:04 pm

If you can not boot the VM you might not be able to boot to the single user. But you can give it a try.

Once you in the single user mode you will need to do this:

Code: Select all
mount -u /
Before doing anything else.
ericbsd
Site Admin
 
Posts: 450
Joined: Mon Nov 19, 2012 11:54 pm

Re: Anybody else having issues with Ports

Postby fmh » Thu Jan 08, 2015 1:50 am

I tried and it stated it needed a fsck.
I ran fsck and it said something about Journalling and y/n so I said Yes and it applied Journaling.
I then was able to mount -u /
then
reboot
and its still won't boot. I started another fresh VM to work with and will delete this one.
fmh
 
Posts: 64
Joined: Wed Jul 23, 2014 5:07 pm

Re: Anybody else having issues with Ports

Postby ericbsd » Thu Jan 08, 2015 2:13 am

Once you do mount -u / you can install software from there like Mate.

What you mean it wont boot?
ericbsd
Site Admin
 
Posts: 450
Joined: Mon Nov 19, 2012 11:54 pm

Re: Anybody else having issues with Ports

Postby fmh » Thu Jan 08, 2015 2:15 am

Just a black screen and no disk activity.
fmh
 
Posts: 64
Joined: Wed Jul 23, 2014 5:07 pm

Re: Anybody else having issues with Ports

Postby fmh » Thu Jan 08, 2015 4:21 pm

I just ended up deleting the VM and started over. There is obviously something wrong in the pkgng repository as many Apps now no longer run once installed stating that dependencies are missing. In time they'll get all fixed. Had the same issue last Summer and a couple of months later it was all good.
fmh
 
Posts: 64
Joined: Wed Jul 23, 2014 5:07 pm

Re: Anybody else having issues with Ports

Postby ericbsd » Fri Jan 09, 2015 12:11 am

The thing is that Gnome2 as been remove from ports and Gnome3 has been added, this as cause issue for sure.
ericbsd
Site Admin
 
Posts: 450
Joined: Mon Nov 19, 2012 11:54 pm

Re: Anybody else having issues with Ports

Postby fmh » Fri Jan 09, 2015 1:31 am

But in the few weeks they did this? In October and November GhostBSD 4.0 32-bit worked fine. Now it's a ### shoot if any package will install let alone work.
fmh
 
Posts: 64
Joined: Wed Jul 23, 2014 5:07 pm

Previous

Return to Installation and Maintenance of software with Ports

Who is online

Users browsing this forum: No registered users and 0 guests

cron