AzureWave AR5B95 support?

Help with setting up network cards, including WiFi cards.

Moderator: Developer

AzureWave AR5B95 support?

Postby ImJune » Sun Jun 14, 2015 8:24 pm

Yeah, this card seems to not be support but the wifi connectivity app.


Any good tips?
ImJune
 
Posts: 5
Joined: Sun Jun 14, 2015 8:03 pm
Location: Kanagawa

AzureWave AR5B95 support?

 

Re: AzureWave AR5B95 support?

Postby ImJune » Sun Jun 14, 2015 10:39 pm

infconfig output:

"wlan0: flags=8802<BROADCAST,SIMPLEX,MULTICAST> metric 0 mtu 1500
ether xxxxxxxxxxxxxxxxxxxxx
nd6 options=29<PERFORMNUD, IFDISABLED,AUTO_LINKLOCAL>
media: IEEE 802.11 Wireless Ethernet autoselect (autoselect)
status: no carrier
ssid " " channel 1 (2412 MHz 11b)
regdomain 96 indoor ecm authmode OPEN privacy OFF txpower 20 bmiss 7
scanvalid 60 wme burst bintval 0"
ImJune
 
Posts: 5
Joined: Sun Jun 14, 2015 8:03 pm
Location: Kanagawa

Re: AzureWave AR5B95 support?

Postby ASX » Mon Jun 15, 2015 6:00 pm

ImJune wrote:infconfig output:

"wlan0: flags=8802<BROADCAST,SIMPLEX,MULTICAST> metric 0 mtu 1500
ether xxxxxxxxxxxxxxxxxxxxx
nd6 options=29<PERFORMNUD, IFDISABLED,AUTO_LINKLOCAL>
media: IEEE 802.11 Wireless Ethernet autoselect (autoselect)
status: no carrier
ssid " " channel 1 (2412 MHz 11b)
regdomain 96 indoor ecm authmode OPEN privacy OFF txpower 20 bmiss 7
scanvalid 60 wme burst bintval 0"


Hi, above in red where the problem lie, now we need to understand why.

Please post the following info, open a terminal and type:
Code: Select all
ifconfig wlan0 scan


additionally, copy and paste the output of the commands:
Code: Select all
kldstat


and:
Code: Select all
dmesg | grep "ath0\|wlan0"


Finally, copy and paste the content of the file /etc/wpa_supplicant.conf too, (redact you private info).
ASX
Developer
 
Posts: 72
Joined: Wed May 06, 2015 3:46 pm
Location: ITALY

Re: AzureWave AR5B95 support?

Postby ImJune » Tue Jun 16, 2015 12:52 am

Ok ifconfig wlan0 scan has zero output.

$kldstat
Id Refs Address Size Name
1 40 0xffffffff80200000 1802000 kernel
2 1 0xffffffff81c12000 3a79 linprocfs.ko
3 1 0xffffffff81c16000 37f01 linux.ko
4 1 0xffffffff81c4e000 24760 vboxguest.ko
5 1 0xffffffff81c73000 4c8 vboxvideo.ko
6 1 0xffffffff81c74000 13298 drm.ko
7 1 0xffffffff81c88000 6070c i915kms.ko
8 1 0xffffffff81ce9000 3feaf drm2.ko
9 1 0xffffffff81d29000 1479 iicbus.ko
10 1 0xffffffff81d2b000 d39 iic.ko
11 1 0xffffffff81d2c000 133d iicbb.ko

# dmesg | grep "ath0\|wlan0"
ath0: <Atheros 9285> mem 0xf7c00000-0xf7c0ffff irq 16 at device 0.0 on pci1
ath0: [HT] enabling HT modes
ath0: [HT] 1 stream STBC receive enabled
ath0: [HT] 1 RX streams; 1 TX streams
ath0: AR9285 mac 192.2 RF5133 phy 14.0
ath0: 2GHz radio: 0x0000; 5GHz radio: 0x00c0
wlan0: Ethernet address: 6c:71:d9:35:be:8d
ImJune
 
Posts: 5
Joined: Sun Jun 14, 2015 8:03 pm
Location: Kanagawa

Re: AzureWave AR5B95 support?

Postby ASX » Tue Jun 16, 2015 12:45 pm

I don't see your /etc/wpa_supplicant.conf file and guess this is the problem: if so, try to add it, like this:

/etc/wpa_supplicant.conf:
Code: Select all
network={
ssid="YourRouterSSID"
psk="YourWpaKey"
}

once done, restart the network interfaces with the following command:
Code: Select all
sudo service netif restart


please report back the output of the following two commands:
Code: Select all
ps auxw | grep wpa
ifconfig wlan0 scan

(wpa_supplicant should be running, list of available access points)
ASX
Developer
 
Posts: 72
Joined: Wed May 06, 2015 3:46 pm
Location: ITALY

Re: AzureWave AR5B95 support?

Postby ImJune » Tue Jun 16, 2015 7:00 pm

$ ps auxw | grep wpa
root 14162 0.2 0.1 21696 5140 - Ss 3:50AM 0:00.13 /usr/sbin/wpa_supplicant -s -B -i wlan0 -c /etc/wpa_supplicant
root 14202 0.0 0.1 21696 5176 - Ss 3:50AM 0:00.15 /usr/sbin/wpa_supplicant -s -B -i wlan0 -c /etc/wpa_supplicant
june 14935 0.0 0.1 18740 2348 0 S+ 3:50AM 0:00.01 grep wpa

Does this look right?
ImJune
 
Posts: 5
Joined: Sun Jun 14, 2015 8:03 pm
Location: Kanagawa

Re: AzureWave AR5B95 support?

Postby ImJune » Tue Jun 16, 2015 7:02 pm

ifconfig wlan scan0 did nothing...
ImJune
 
Posts: 5
Joined: Sun Jun 14, 2015 8:03 pm
Location: Kanagawa

Re: AzureWave AR5B95 support?

Postby ASX » Tue Jun 16, 2015 8:02 pm

ImJune wrote:$ ps auxw | grep wpa
root 14162 0.2 0.1 21696 5140 - Ss 3:50AM 0:00.13 /usr/sbin/wpa_supplicant -s -B -i wlan0 -c /etc/wpa_supplicant
root 14202 0.0 0.1 21696 5176 - Ss 3:50AM 0:00.15 /usr/sbin/wpa_supplicant -s -B -i wlan0 -c /etc/wpa_supplicant
june 14935 0.0 0.1 18740 2348 0 S+ 3:50AM 0:00.01 grep wpa

Does this look right?


No, at any time only one instance of wpa_supplicant should be running, if happens to have more than one, try:

Code: Select all
sudo killall wpa_supplicant
sudo service netif restart
ASX
Developer
 
Posts: 72
Joined: Wed May 06, 2015 3:46 pm
Location: ITALY

Re: AzureWave AR5B95 support?

Postby ASX » Tue Jun 16, 2015 8:03 pm

open a terminal, su to root with
Code: Select all
su -

for test reasons, we rename temporarily wpa_supplicant.conf

Code: Select all
mv /etc/wpa_supplicant.conf /etc/wpa_supplicant.backup
killall -9 wpa_supplicant


then, test as follow:

Code: Select all
ifconfig ath0 up
ifconfig wlan0 destroy
ifconfig wlan0 create wlandev ath0
ifconfig wlan0 up
ifconfig wlan0 scan


you should get from the last command a list of available access point, is so continue with:
EDITED the command because of the .backup config file
Code: Select all
wpa_supplicant -B -i wlan0 -c /etc/wpa_supplicant.backup
dhclient wlan0


if connection succeed now you should see an IP address assigned to wlan0, and you should be able to ping outside:
Code: Select all
ifconfig wlan0
ping 8.8.8.8
ASX
Developer
 
Posts: 72
Joined: Wed May 06, 2015 3:46 pm
Location: ITALY


Return to Networking

Who is online

Users browsing this forum: No registered users and 0 guests

cron