Installer very broken. 4.0, AMD64 [SOLVED]  [SOLVED]

Questions about the installation of FreeBSD

Installer very broken. 4.0, AMD64 [SOLVED]

Postby KE0ETP » Thu Jun 18, 2015 2:57 pm

I am trying to install GhostBSD on to my machine, but even when i assign a root and boot partition it says i have not. The layout i attempt is: 256mb freebsd-boot, 10gb freebsd-ufs (with SUJ) on root (/), and 287gb freebsd-ufs (no SUJ for SUSE compatibility) on /home, 100mb swap.
I was once able to get it to install with this layout, but it kept trying to unmount ada0p3, which was not even mounted! I have the log from the one time it did work. why does umount throw "unknown file system" instead of something along the lines of "device not mounted"?

Code: Select all
kern.geom.debugflags: 0 -> 16
Running: gpart modify -t freebsd-boot -i 1 /dev/ada0
ada0p1 modified
Stamping boot sector on /dev/ada0
Running: gpart bootcode -b /boot/pmbr /dev/ada0
bootcode written to ada0
Running: gpart add -s 10240M -t freebsd-ufs /dev/ada0
ada0p2 added
Running: gpart add -s 294805M -t freebsd-ufs /dev/ada0
ada0p3 added
Running: gpart add -s 100M -t freebsd-swap /dev/ada0
ada0p4 added
Running: gpart add -s 10240M -t freebsd-ufs /dev/ada0
gpart: autofill: No space left on device
EXITERROR: Error 1: gpart add -s 10240M -t freebsd-ufs /dev/ada0
Unmounting: /dev/ada0p3
Running: umount -f /dev/ada0p3
umount: /dev/ada0p3: unknown file system
Screenshot-1.png (172.3 KiB) Viewed 2034 times
Screenshot.png (173.08 KiB) Viewed 2034 times
Last edited by KE0ETP on Sat Jun 20, 2015 7:25 pm, edited 1 time in total.
Posts: 2
Joined: Thu Jun 18, 2015 1:39 pm
Has thanked: 0 time
Been thanked: 0 time

Installer very broken. 4.0, AMD64 [SOLVED]

Re: Installer very broken. 4.0, AMD64  [SOLVED]

Postby ASX » Fri Jun 19, 2015 2:57 am

Hi KE0ETP and thank you for your report.

We are aware of the partition-editor problems and we are actively working to solve it, most likely will be fixed in the upcoming beta.

One of the known limitation is that the partitions actually must be added in a very specific order:

for GPT based partitions schemes:
- freebsd-boot -> none
- freebsd-ufs -> '/'
- Swap -> none
- others

for MBR partitions schemes:
- freebsd-ufs -> '/'
- Swap -> none
- others

Additionally, editing (delete/create/modify) partitions entries may or may not work properly, so I strongly suggest to restart from the beginning if some changes is required, (I mean, cancel the installation and restart), and looking at your log it seems to me it was the case here.

Also, allow for at least 20 GB for '/' partition, 10 Gb could become too small very quickly, as soon as you add apps, updates, and so on.
Setting a UFS '/' partition without journaling and soft updates should also work, that would allow you to avoid a separate /home filesystem.

Finally freebsd-boot is a partition which will contains the bootloader-code, to not be confused with a /boot partition which instead would contains kernel, modules and loader config files, so its size can be safely limited to 64Kb.

Adding a separate /boot partition, actually will not work, yeah, we know that too.
Posts: 970
Joined: Wed May 06, 2015 11:46 am
Has thanked: 58 times
Been thanked: 130 times

Re: Installer very broken. 4.0, AMD64

Postby KE0ETP » Fri Jun 19, 2015 7:18 pm

[s]ok, well. it tried installing, but then the installer crashed. its been 8hrs since i tried the installer again, and it still didnt install. im going to try FreeBSD and see how that goes.[/s]
edit: DOH! I told UEFI to try and boot it as a BIOS disk, not GPT EFI disk. it installed fine :oops:
Posts: 2
Joined: Thu Jun 18, 2015 1:39 pm
Has thanked: 0 time
Been thanked: 0 time

Return to Installing GhostBSD

Who is online

Users browsing this forum: No registered users and 2 guests