4.0 ALPHA 1 Installer unable to write partitions

Discuss development of the GhostBSD system installer.

4.0 ALPHA 1 Installer unable to write partitions

Postby detharonil » Sun Mar 09, 2014 8:27 pm

With both default (Entire Disk) partitioning and a custom layout, the installer is able to delete but not write partitions to disk. The live image is still active and accessible, but the installation cannot proceed, the "Next" and "Add" buttons in the Entire Disk and Partition Editor menus, respectively, simply do not function.

The installation was performed with the i386 LiveUSB image, whose integrity was verified by a md5sum check. I'm not sure if it has anything to do with the failure, but my disks are MBR only due to their age; I am unable to test the installer with GPT partitions.

Below is a dmesg of the live image. Let me know if more information is needed.

Code: Select all
Copyright (c) 1992-2014 The FreeBSD Project.
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
   The Regents of the University of California. All rights reserved.
FreeBSD is a registered trademark of The FreeBSD Foundation.
FreeBSD 10.0-RELEASE #0: Tue Mar  4 22:49:17 AST 2014
    root@ericbsd.ghostbsd.org:/usr/obj/i386.i386/usr/src/sys/GHOSTBSD i386
FreeBSD clang version 3.3 (tags/RELEASE_33/final 183502) 20130610
CPU: Intel(R) Atom(TM) CPU N270   @ 1.60GHz (1596.03-MHz 686-class CPU)
  Origin = "GenuineIntel"  Id = 0x106c2  Family = 0x6  Model = 0x1c  Stepping = 2
  Features=0xbfe9fbff<FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,CLFLUSH,DTS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE>
  Features2=0x40c39d<SSE3,DTES64,MON,DS_CPL,EST,TM2,SSSE3,xTPR,PDCM,MOVBE>
  AMD Features=0x100000<NX>
  AMD Features2=0x1<LAHF>
  TSC: P-state invariant, performance statistics
real memory  = 2147483648 (2048 MB)
avail memory = 2072739840 (1976 MB)
Event timer "LAPIC" quality 400
ACPI APIC Table: <051109 APIC1655>
FreeBSD/SMP: Multiprocessor System Detected: 2 CPUs
FreeBSD/SMP: 1 package(s) x 1 core(s) x 2 HTT threads
 cpu0 (BSP): APIC ID:  0
 cpu1 (AP/HT): APIC ID:  1
ioapic0: Changing APIC ID to 2
ioapic0 <Version 2.0> irqs 0-23 on motherboard
kbd1 at kbdmux0
random: <Software, Yarrow> initialized
acpi0: <051109 RSDT1655> on motherboard
acpi0: Power Button (fixed)
acpi0: reservation of 0, a0000 (3) failed
acpi0: reservation of 100000, 7f700000 (3) failed
cpu0: <ACPI CPU> on acpi0
cpu1: <ACPI CPU> on acpi0
attimer0: <AT timer> port 0x40-0x43 irq 0 on acpi0
Timecounter "i8254" frequency 1193182 Hz quality 0
Event timer "i8254" frequency 1193182 Hz quality 100
atrtc0: <AT realtime clock> port 0x70-0x71 irq 8 on acpi0
Event timer "RTC" frequency 32768 Hz quality 0
Timecounter "ACPI-fast" frequency 3579545 Hz quality 900
acpi_timer0: <24-bit timer at 3.579545MHz> port 0x808-0x80b on acpi0
acpi_ec0: <Embedded Controller: GPE 0x17> port 0x62,0x66 on acpi0
pcib0: <ACPI Host-PCI bridge> port 0xcf8-0xcff on acpi0
pci0: <ACPI PCI bus> on pcib0
vgapci0: <VGA-compatible display> port 0xdc80-0xdc87 mem 0xfe980000-0xfe9fffff,0xd0000000-0xdfffffff,0xfe940000-0xfe97ffff irq 16 at device 2.0 on pci0
agp0: <Intel 945GME SVGA controller> on vgapci0
agp0: aperture size is 256M, detected 7932k stolen memory
vgapci0: Boot video device
vgapci1: <VGA-compatible display> mem 0xfe880000-0xfe8fffff at device 2.1 on pci0
hdac0: <Intel 82801G HDA Controller> mem 0xfe938000-0xfe93bfff irq 16 at device 27.0 on pci0
pcib1: <ACPI PCI-PCI bridge> irq 16 at device 28.0 on pci0
pci1: <ACPI PCI bus> on pcib1
pci1: <network> at device 0.0 (no driver attached)
pcib2: <ACPI PCI-PCI bridge> irq 17 at device 28.1 on pci0
pci2: <ACPI PCI bus> on pcib2
mskc0: <Marvell Yukon 88E8040 Fast Ethernet> port 0xec00-0xecff mem 0xfebfc000-0xfebfffff irq 17 at device 0.0 on pci2
msk0: <Marvell Technology Group Ltd. Yukon FE+ Id 0xb8 Rev 0x00> on mskc0
msk0: disabling jumbo frame support
msk0: Ethernet address: 00:25:b3:64:7d:61
miibus0: <MII bus> on msk0
e1000phy0: <Marvell 88E3016 10/100 Fast Ethernet PHY> PHY 0 on miibus0
e1000phy0:  none, 10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto, auto-flow
uhci0: <Intel 82801G (ICH7) USB controller USB-A> port 0xdc00-0xdc1f irq 23 at device 29.0 on pci0
uhci0: LegSup = 0x3f00
usbus0 on uhci0
uhci1: <Intel 82801G (ICH7) USB controller USB-B> port 0xd880-0xd89f irq 19 at device 29.1 on pci0
uhci1: LegSup = 0x2f00
usbus1 on uhci1
uhci2: <Intel 82801G (ICH7) USB controller USB-C> port 0xd800-0xd81f irq 18 at device 29.2 on pci0
uhci2: LegSup = 0x2f00
usbus2 on uhci2
uhci3: <Intel 82801G (ICH7) USB controller USB-D> port 0xd480-0xd49f irq 16 at device 29.3 on pci0
uhci3: LegSup = 0x2f00
usbus3 on uhci3
ehci0: <Intel 82801GB/R (ICH7) USB 2.0 controller> mem 0xfe937c00-0xfe937fff irq 23 at device 29.7 on pci0
usbus4: EHCI version 1.0
usbus4 on ehci0
pcib3: <ACPI PCI-PCI bridge> at device 30.0 on pci0
pci3: <ACPI PCI bus> on pcib3
isab0: <PCI-ISA bridge> at device 31.0 on pci0
isa0: <ISA bus> on isab0
atapci0: <Intel ICH7 UDMA100 controller> port 0x1f0-0x1f7,0x3f6,0x170-0x177,0x376,0xffa0-0xffaf at device 31.1 on pci0
ata0: <ATA channel> at channel 0 on atapci0
pci0: <serial bus, SMBus> at device 31.3 (no driver attached)
acpi_button0: <Sleep Button> on acpi0
acpi_button1: <Power Button> on acpi0
acpi_tz0: <Thermal Zone> on acpi0
acpi_lid0: <Control Method Lid Switch> on acpi0
atkbdc0: <Keyboard controller (i8042)> port 0x60,0x64 irq 1 on acpi0
atkbd0: <AT Keyboard> irq 1 on atkbdc0
kbd0 at atkbd0
atkbd0: [GIANT-LOCKED]
psm0: <PS/2 Mouse> flags 0x1000 irq 12 on atkbdc0
psm0: [GIANT-LOCKED]
psm0: model Generic PS/2 mouse, device ID 0
battery0: <ACPI Control Method Battery> on acpi0
acpi_acad0: <AC Adapter> on acpi0
pmtimer0 on isa0
sc0: <System console> at flags 0x100 on isa0
sc0: VGA <16 virtual consoles, flags=0x300>
vga0: <Generic ISA VGA> at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
ppc0: parallel port not found.
est0: <Enhanced SpeedStep Frequency Control> on cpu0
p4tcc0: <CPU Frequency Thermal Control> on cpu0
est1: <Enhanced SpeedStep Frequency Control> on cpu1
p4tcc1: <CPU Frequency Thermal Control> on cpu1
Timecounters tick every 1.000 msec
hdacc0: <IDT 92HD75B3 HDA CODEC> at cad 0 on hdac0
hdaa0: <IDT 92HD75B3 Audio Function Group> at nid 1 on hdacc0
pcm0: <IDT 92HD75B3 (Analog 2.0+HP/2.0)> at nid 13,10 and 11,14 on hdaa0
random: unblocking device.
usbus0: 12Mbps Full Speed USB v1.0
usbus1: 12Mbps Full Speed USB v1.0
usbus2: 12Mbps Full Speed USB v1.0
usbus3: 12Mbps Full Speed USB v1.0
usbus4: 480Mbps High Speed USB v2.0
ugen1.1: <Intel> at usbus1
uhub0: <Intel UHCI root HUB, class 9/0, rev 1.00/1.00, addr 1> on usbus1
ugen0.1: <Intel> at usbus0
uhub1: <Intel UHCI root HUB, class 9/0, rev 1.00/1.00, addr 1> on usbus0
ugen3.1: <Intel> at usbus3
uhub2: <Intel UHCI root HUB, class 9/0, rev 1.00/1.00, addr 1> on usbus3
ugen2.1: <Intel> at usbus2
uhub3: <Intel UHCI root HUB, class 9/0, rev 1.00/1.00, addr 1> on usbus2
ugen4.1: <Intel> at usbus4
uhub4: <Intel EHCI root HUB, class 9/0, rev 2.00/1.00, addr 1> on usbus4
ada0 at ata0 bus 0 scbus0 target 0 lun 0
ada0: <SanDisk pSSD 16GB SSD 4.46> ATA-4 device
ada0: Serial Number DDZ053109183333
ada0: 66.700MB/s transfers (UDMA4, PIO 2048bytes)
ada0: 15631MB (32014080 512 byte sectors: 16H 63S/T 16383C)
ada0: Previously was known as ad0
SMP: AP CPU #1 Launched!
Root mount waiting for: usbus4 usbus3 usbus2 usbus1 usbus0
uhub0: 2 ports with 2 removable, self powered
uhub1: 2 ports with 2 removable, self powered
uhub2: 2 ports with 2 removable, self powered
uhub3: 2 ports with 2 removable, self powered
Root mount waiting for: usbus4
Root mount waiting for: usbus4
Root mount waiting for: usbus4
uhub4: 8 ports with 8 removable, self powered
Root mount waiting for: usbus4
ugen4.2: <Corsair> at usbus4
umass0: <Corsair Survivor 3.0, class 0/0, rev 2.10/0.00, addr 2> on usbus4
umass0:  SCSI over Bulk-Only; quirks = 0x4100
umass0:1:0:-1: Attached to scbus1
da0 at umass-sim0 bus 0 scbus1 target 0 lun 0
da0: <Corsair Survivor 3.0 1.00> Removable Direct Access SCSI-4 device
da0: Serial Number 12470041800018240074
da0: 40.000MB/s transfers
da0: 15300MB (31334400 512 byte sectors: 255H 63S/T 1950C)
da0: quirks=0x2<NO_6_BYTE>
Root mount waiting for: usbus4
ugen4.3: <Image Processor> at usbus4
Trying to mount root from ufs:/dev/ufs/GhostBSD [ro,noatime]...
md0.uzip: 92815 x 65536 blocks
drm0: <Intel i945GME> on vgapci0
info: [drm] AGP at 0xd0000000 256MB
info: [drm] Initialized i915 1.6.0 20080730
detharonil
 
Posts: 1
Joined: Sun Mar 09, 2014 8:05 pm

4.0 ALPHA 1 Installer unable to write partitions

 

Re: 4.0 ALPHA 1 Installer unable to write partitions

Postby ericbsd » Sun Mar 09, 2014 8:37 pm

Thanks for reporting.
ericbsd
Site Admin
 
Posts: 404
Joined: Mon Nov 19, 2012 11:54 pm


Return to GhostBSD Installer

Who is online

Users browsing this forum: No registered users and 0 guests

cron