OPenGL is not Working

Help with graphics cards on GhostBSD.

Moderator: Developer

OPenGL is not Working

Postby leegold » Wed Aug 13, 2014 11:06 pm


$ uname -a
FreeBSD freebsd-963 9.2-RELEASE FreeBSD 9.2-RELEASE #0: Mon Oct 21 21:22:37 ADT 2013 i386

I have an nvidia card.
Code: Select all
$ kldstat
Id Refs Address    Size     Name
 1   21 0xc0400000 106bbbc  kernel
 2    1 0xc146c000 755fa8   nvidia.ko
 3    2 0xc1bc2000 32150    linux.ko
 4    1 0xc7cf3000 2b000    vboxguest.ko
 5    1 0xc7d25000 2000     vboxvideo.ko
 6    1 0xc7d27000 16000    drm.ko
 7    1 0xc86a2000 b000     ntfs.ko

I noted that none of the OpenGL screensavers work. They run in Linux...Isn't OpenGl the 3-D capability? It's not essential but it would be interesting to know why it's not working.

Possibly related is when I run nvidia-settings I get:
Code: Select all
$ nvidia-settings

ERROR: libGL setup error : Shared object "" not found, required by

and then nvidia-settings opens, when I look at "OpenGL/GLX Info in nvidia-settings GUI there's no info just says: Failed to query the GLX server vendor.

Is there a fix? I looked at xorg.config and it seems OK(?):
Code: Select all
[user1@freebsd-963 /usr/home/user1]$ cat /etc/X11/xorg.conf
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 310.14  (root@9-1405)  Sun Jul 21 14:31:51 UTC 2013

Section "ServerLayout"
    Identifier     " Configured"
    Screen      0  "Screen0"
    InputDevice    "Mouse0" "CorePointer"
    InputDevice    "Keyboard0" "CoreKeyboard"

Section "Files"
    ModulePath      "/usr/local/lib/xorg/modules"
    FontPath        "/usr/local/lib/X11/fonts/misc/"
    FontPath        "/usr/local/lib/X11/fonts/TTF/"
    FontPath        "/usr/local/lib/X11/fonts/OTF"
    FontPath        "/usr/local/lib/X11/fonts/Type1/"
    FontPath        "/usr/local/lib/X11/fonts/100dpi/"
    FontPath        "/usr/local/lib/X11/fonts/75dpi/"

Section "Module"
    Load           "dbe"
    Load           "dri2"
    Load           "glx"
    Load           "extmod"
    Load           "record"

Section "InputDevice"
    Identifier     "Keyboard0"
    Driver         "kbd"

Section "InputDevice"
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/sysmouse"
    Option         "ZAxisMapping" "4 5 6 7"

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Monitor Vendor"
    ModelName      "Monitor Model"
    HorizSync      30.0 - 80.0
    VertRefresh    60.0
    Option       "DPMS"

Section "Device"
    Identifier     "Device0"      #"Card1"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    # BoardName      "NV34 [GeForce FX 5200]"
    # BusID          "PCI:1:5:0"

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth     24
    SubSection     "Display"
        Depth 24
        Modes "1280x1024"  "1024x768"
Posts: 20
Joined: Wed Aug 28, 2013 2:58 pm

OPenGL is not Working

Re: OPenGL is not Working

Postby bsdkeith » Thu Aug 14, 2014 7:14 am

I notice that the BoardName & BusID are commented out, have you tried uncommenting them to see what happens?
Code: Select all
# BoardName      "NV34 [GeForce FX 5200]"
    # BusID          "PCI:1:5:0"
Linux user since 1999; & now a BSD user.
User avatar
Posts: 129
Joined: Wed Jun 12, 2013 6:36 pm
Location: Surrey/Hants Border, England

Re: OPenGL is not Working

Postby leegold » Fri Aug 15, 2014 3:49 am

Please stand-by I'm installing ver 4 rc 1.
Posts: 20
Joined: Wed Aug 28, 2013 2:58 pm

Re: OPenGL is not Working

Postby ericbsd » Sat Aug 16, 2014 9:56 pm

I have uploaded rc2, but I have not tested yet.
Posts: 718
Joined: Mon Nov 19, 2012 11:54 pm

Return to Graphics Cards

Who is online

Users browsing this forum: No registered users and 0 guests